«     Октябрь 2013    »
Пн Вт Ср Чт Пт Сб Вс
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
 

Выбор адаптера OBDII

  1. Apple iOS (iPhone / iPad)
  2. Google Android
  3. Windows 8.1, Windows 10, Windows Phone 8.1, Windows Mobile 10

Автосканер совместим с адаптерами OBDII на основе ELM327 , работающими через классический Bluetooth (ver.1.x, 2.x, 3.x), Bluetooth LE (4.0) или Wi-Fi, в зависимости от операционной системы вашего устройства.
Вы можете найти его на eBay, Amazon, Aliexpress, Google или Bing, используя ключевые слова «elm327 bluetooth» или «elm327 wifi».

В зависимости от типа подключения адаптеры можно разделить на 3 группы:

  1. Wi-Fi
  2. Bluetooth (классический, версии 1.х, 2.х, 3.х)
  3. Bluetooth LE (версия 4.0 и выше)

Apple iOS (iPhone / iPad)

Apple iOS (iPhone / iPad) поддерживает адаптеры Bluetooth LE (4.0) и Wi-Fi. Адаптеры с «классическим» Bluetooth (версии 1.х, 2.х, 3.х) несовместимы с iPhone / iPad из-за ограничений Apple iOS.

Адаптеры Bluetooth 4.0 имеют ряд преимуществ по сравнению с адаптерами Wi-Fi:

1) Адаптеры Wi-Fi могут мешать работе мобильного интернета, адаптеры Bluetooth 4.0 не мешают работе мобильного интернета.

2) Apple iOS позволяет Car Scanner работать с адаптерами Bluetooth LE (4.0) в фоновом режиме, даже когда окно Car Scanner свернуто. К сожалению, в iOS нет возможности использовать адаптер Wi-Fi, пока приложение находится в фоновом режиме. Это ограничение Apple iOS, и нет способа его преодолеть.

3) Некоторые адаптеры Wi-Fi не совместимы с iOS 11: Apple iOS 11 просто не маршрутизирует трафик в сеть Wi-Fi адаптера (зависит от конфигурации сети адаптера).

Поэтому я рекомендую использовать адаптеры Bluetooth 4.0 с устройствами iOS (iPhone / iPad).

Пожалуйста, обратите внимание на версию Bluetooth. Это очень-очень важно для iPhone / iPad! Каждый день я получаю несколько писем от пользователей, которые заказали адаптер OBDII с «классическим» Bluetooth (не Bluetooth 4.0), и мне приходится их разочаровывать: адаптеры с классическим Bluetooth (ver.1.x, 2.x, 3.x) абсолютно не совместим с Apple iOS. Нет возможности использовать их. Там нет приложений, которые могут их использовать. Эти ограничения исходят от Apple iOS, и нет способа их преодолеть.

Google Android

Google Android поддерживает адаптеры с «классическим» Bluetooth (версии 1.х, 2.х, 3.х) и Wi-Fi.

Адаптер Bluetooth 4.0 не поддерживается автомобильным сканером на Android.

Windows 8.1, Windows 10, Windows Phone 8.1, Windows Mobile 10

Car Scanner для Windows поддерживает адаптеры с «классическим» Bluetooth (версии 1.х, 2.х, 3.х) и Wi-Fi.

Цена адаптера от 5 до 100 долларов. Какой я должен купить?

Вы должны знать, что большинство дешевых адаптеров (с ценой <$ 50) на самом деле НЕ являются ELM327. Это китайские клоны, претендующие на звание ELM327, действующие как ELM327.

Что плохого в «клонах»?

Покупка дешевого китайского клона похожа на игру против казино - казино всегда побеждает.

Большинство «клонов» имеют разные ошибки.

На самом деле существует несколько «настоящих» версий китайских клонов:

  1. Старые клоны, помеченные как «v.1.4» или «v.1.5», были построены очень хорошо, поддерживали 90% набора команд ELM327 и в большинстве случаев работали как оригинальный ELM327 без каких-либо ошибок. Сейчас очень сложно найти такого хорошего клона.
  2. Более новые клоны с пометкой «v.2.1». Это мир дерьма. 100% этих клонов имеют ошибки (см. Список известных ошибок ниже). Если вы видите дешевый ELM327, помеченный как «v.2.1», ИЗБЕГАЙТЕ КУПИТЬ ЭТУ КРЕПА!
  3. Умные китайские фальшивомонетчики, которые заставили клонов v.2.1 понять, что потребители предпочитают покупать клоны ELM327, помеченные как «v.1.4» или «v.1.5», и не хотят покупать «v.2.1», что был полон ошибок. Итак, что они сделали? Они просто изменили строку версии в «v.2.1» на «v.1.5». И у нас есть клоны «v.2.1», но помеченные как «v.1.5». Это просто кусок дерьма, как v.2.1 с измененной версией строки.

Вот список известных ошибок с «плохими» клонами:

  1. 100% из них не поддерживают полный набор команд ELM327. Некоторые из них даже не поддерживают основные команды.
  2. Некоторые из них не поддерживают все протоколы, поддерживаемые оригинальным ELM327. Большинство v.2.1 не поддерживают SAE J1850 PWM / VPM, поэтому вы не можете подключиться к старым автомобилям Buick, Cadillac, Chevrolet, Chrysler, Dodge, GM, Isuzu, Ford, Lincoln, Mazda.
  3. Некоторые из них не могут подключаться к разным транспортным средствам. Большинство «плохих» клонов не могут подключиться к Nissan / Infinity / Datsun.
  4. Большинство из них не могут подключиться с помощью расширенных строк инициализации к автомобилям, которые не полностью поддерживают OBD2.
  5. Они теряют пакеты данных. Например, когда вы запрашиваете VIN-код у вашего автомобиля, вы получаете только 2/3 VIN-кода, потому что несколько пакетов данных были потеряны из-за плохого клона.
  6. Некоторые данные датчика могут быть переданы с неправильными значениями. У меня есть клон, который всегда показывал температуру охлаждающей жидкости автомобиля +25 C. Даже если она была 0 C или 80 C 🙂
  7. У них обычно тормозит связь, зависает и т. Д.

Итак, какой адаптер я должен купить?

Лучшие из лучших - на основе оригинального (оригинального) чипа ELM327 версии 1.4 или 2.1.

Если это слишком дорого, попробуйте купить клон, помеченный как «v1.4» или «v.1.5», по цене от 20 долларов.

Если вы купите дешевый адаптер за 5-10 долларов, на 99% это будут клоны v2.1.

Некоторые пользователи считают клоны, помеченные как «Vgate», как хорошие, но вы также можете купить «клон» из «Vgate clone», который будет клоном «v.2.1» с наклейкой Vgate.

Почему так важно купить хороший адаптер? Разве это не простой передатчик?

На самом деле адаптер на основе ELM327 - это не просто передатчик. Это «маленький компьютер», который на самом деле обрабатывает все коммуникации с автомобилем.

Это не программное обеспечение, которое на самом деле подключается к ECU вашего автомобиля, это чип ELM327. Он может обрабатывать около 10 вариантов базовых протоколов и интерпретировать информацию из этих протоколов в один.

Таким образом, если у вас плохой «переводчик», ваше программное обеспечение (Car Scanner) и автомобильный ECU не будут понимать друг друга. Но если у вас есть хороший «переводчик», у них будет очень интересный разговор, и вы получите всю необходимую информацию.

Прежде всего, я не продаю адаптеры! Все мои советы основаны на моем собственном опыте и отзывах пользователей.

Для всех устройств (iOS, Android, Windows) я рекомендую Viecar Bluetooth 4, который выглядит следующим образом: белый, с прямым (не Т-образным) корпусом, упакованный в фирменную пластиковую коробку. Это стоит около 15-25 грн.

Важное примечание: я не рекомендую все адаптеры от Viecar, только одну конкретную модель, которую я описал!

Этот адаптер имеет чип Bluetooth 2.0 + Bluetooth 4.0, поэтому он совместим со всеми операционными системами (iOS, Android, Windows).

Вы можете купить его в интернет-магазинах, таких как Amazon, Aliexpress.com, eBay.com и т. Д.

Альтернативный вариант: Veepeak OBDCheck BLE .

Альтернативный вариант: Veepeak OBDCheck BLE

Этот адаптер имеет чип Bluetooth 2.0 + Bluetooth 4.0, поэтому он совместим со всеми операционными системами (iOS, Android, Windows).

Вы можете купить его в разных интернет-магазинах, таких как Amazon. Вы можете использовать промо-код OBDAPP20, чтобы получить скидку 20%.

Альтернативный вариант только для iOS (iPhone / iPad): KONNWEI KW903 Bluetooth .

ВНИМАНИЕ: не покупайте KONNWEI KW903 Wi-Fi ! Это адаптеры всего дерьмо!

Если вы хотите купить другую модель адаптера - попробуйте найти какой-нибудь «фирменный» адаптер и не покупайте адаптеры без названий!

  1. Никогда не покупайте адаптеры xTool, поскольку они несовместимы с ELM327 и могут использоваться только с собственным программным обеспечением.
  2. Не покупайте проводные адаптеры (USB, Com) - Car Scanner поддерживает только беспроводные адаптеры.
  3. Никогда не покупайте адаптер со словом «мини» в названии. Есть шанс 99% купить «плохой» адаптер.
  4. Не покупайте дешевые (<10 $) адаптеры.
  5. Адаптеры с MAC-адресом Bluetooth, начиная с 11:22:33 и 00:00:00
  6. KONNWEI KW903 Wi-Fi (Bluetooth 4.0 версия этого адаптера хорошая)
  7. Назван «Микромеханик» (многие из них перестают работать через короткий промежуток времени)
  8. Не покупайте адаптеры, которые выглядят так (они совместимы, но большинство из них очень низкого качества):

0 версия этого адаптера хорошая)   Назван «Микромеханик» (многие из них перестают работать через короткий промежуток времени)   Не покупайте адаптеры, которые выглядят так (они совместимы, но большинство из них очень низкого качества):

Карта